Authentication issue

Incident Report for Bugcrowd

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 19:15 PDT

Monitoring

We've implemented a remediation and are now recovering.
Posted Jul 24, 2025 - 18:28 PDT

Investigating

We're currently working with a vendor to resolve an issue in our authentication processes, at the moment new users, users who haven't haven't logged in for awhile, and users who have changed their password will be unable to login to the platform.
Posted Jul 24, 2025 - 14:33 PDT
This incident affected: identity.bugcrowd.com.