Outbound platform emails not sending

Incident Report for Bugcrowd

Resolved

Email sending from the platform is functional again.
Posted Apr 10, 2025 - 23:50 PDT

Identified

We've identified another issue that is preventing us from sending platform emails and are working with our vendor to get it resolved but there is no ETA currently.
Posted Apr 10, 2025 - 10:00 PDT
This incident affected: bugcrowd.com && tracker.bugcrowd.com.